……Marco Valli's Blog……

Internet, Tecnologia e SharePoint!!!

Telecronaca di un successo…


Il fatto: mercoledì sera mi chiama il mio colelga, dopo aver parlato del più e del meno, mi dice che c’è un problema, un nostro cliente, che non ci ha mai chiamati (se non per problemini vari..) e che si è installato da solo Windows Sharepoint Services 3.0 (configurandolo non so come) ha avuto un problema: lo sharepoint non parte più… dopo qualche ragionamento e dopo aver appurato che lui non poteva andarci perchè già impegnato (il tanto atteso porting sui server del cliente del grosso progetto Sharepoint..) è emerso che il designato per l’operazione di salvataggio…

Gli eventi: arrivo alle 8.30 in punto dal cliente e comincio a dare un’occhiata, le premesse non sono incoraggianti: il disaster recovery schedulato con cura NON HA FUNZIONATO e il più recente disponibile risale a Marzo… (per la serie "cominciamo bene…")… Nessun problema, allora guardiamo il database… per fortuna almeno quello era presente ed aggiornato alla data di ieri…(meno male!!)

Dopo qualche tentativo iniziale dovuto al fatto che tutto sembra nato dal cambiamento di password dell’amministratore di rete, utente con il quale hanno pensato (malissimo!!!) di installare lo sharepoint… Quindi test di reimpostazione password dell’account (niente), test di reset della password con la procedura per sharepoint:

  1. impossibile cambiare la password perchè l’amministratore dell’application pool ha un problema
  2. al tentativo di reimpostare l’account dell’application pool mi viene restituito un errore che generico è dire poco (qualche decina di migliaia di risultati su google…)

La tensione sale.. mi faccio una copia del database, parto con il ripristino dello sharepoint tramite psconfig e aspetto… La procedura è lunga ma alla fine termina correttamente, ora la central administration funziona e ho un bellissimo sito principale (VUOTO naturalmente..) faccio qualche tentativo di ricollegare il vecchio database tramite l’interfaccia perl’SQL express ma i tentativi sono vani, non è possibile attaccare il database….

Altro tentativo: prendo il database, avvio una delle virtual machine di test che uso per sperimentare con Sharepoint e provo a fare la stessa cosa: in 15 minuti ho di fronte a me il sito del cliente funzionante… che dire spettacolo!!!!

Adesso il problema è solo riportare il tutto sul server del cliente… fortunatamente riesco ad ottenere dal cliente la possibilità di installare SQL Server 2005 quindi si riparte da 0: disisntalla tutto quanto, fai tutti gli aggiornamenti (SQL SP2 + patch + patch .NET + varie altre patch..), riscarica i WSS3 SP1 + language pack SP1 italiano + reinstalla tutto, configuralo correttamente e fai partire il tutto…

Risultato delle operazioni, uno sharepoint pulito e funzionale con database su SQL… creo la web application e procedo tranquillamente alla creazione della prima site collection ma… stranamente invece di mostrarmi l’url del server e poi la casella a discesa per il managed path e basta, mi visualizza il managed path e lo spazio bianco, come se fosse una qualunque site collection… Si ricomincia a provare, rimuovi la web application e reinstallala… ancora lo stesso problema… Faccio il test sulla virtual machine e il tutto funziona correttamente (non mi chiede l’url ma solo il managed path così come dovrebbe fare…)..

Che si fa? facciamo l’ultima prova prima di cadere nello sconforto: proviamo a ricaricare i database senza aver proprio ripristinato lo stesso ambiente iniziale (manca infatti la prima site collection)… il SQL carica correttamente i database… dalla central administration non mi fa collegare il content database perchè mi dice che devo farlo da riga di comando… lo accontento, quindi via di stsadm… qualche attimo di concentrazione… mi dice di attendere… operazione effettuata correttamente… aspetto prima di festeggiare…

Apro il browser, scrivo semplicemente "intranet" ed ecco quello che volevo: l’intranet del cliente perfettamente ripristinato e funzionante… vi lascio immaginare la goduria estrema….

L’impostazione del disaster recovery (fuzionante questa volta!!! 😉 ) la schedulazione e tutto il resto è stata solo una pura formalità….

Conclusione: 11 ore di rapportino di intervento + urgenza + io che sono devastato….. ma soddisfatto!!!! 🙂

Ringraziamenti: Alessandro, il mio collega senza il quale non sarei sicuramente riuscito a risolvere tutte le magagne del giorno e senza il quale non avrei mai scoperto il meraviglioso mondo di sharepoint….

ByeZz!! 🙂

Annunci

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger hanno fatto clic su Mi Piace per questo: